$re = '/(?:"|(\d+),)|(\.\d+)"(?=,)/';
$str = '."123,456,789,012.999",';
$subst = "\1\2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;