re = /(?:"|(\d+),)|(\.\d+)"(?=,)/
str = '."123,456,789,012.999",'
subst = '\\1\\2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result