import Foundation
let pattern = #"(?:"|(\d+),)|(\.\d+)"(?=,)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"."123,456,789,012.999","#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1\2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)