using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\{(?:(?:A=1()|B=2()|C=3())(?>,|\}$)){3}\1\2\3$";
string input = @"{A=1,B=2,C=3}
{B=2,A=1,C=3}
{C=3,B=2,A=1}
{A=1,B=2,A=1}
{B=2,B=2,C=3}
{A=1B=2C=3}
{A=1}B=2}C=3}
{C=3,B=2,A=1,}";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}