re = /^\{(?:(?:A=1()|B=2()|C=3())(?>,|\}$)){3}\1\2\3$/m
str = '{A=1,B=2,C=3}
{B=2,A=1,C=3}
{C=3,B=2,A=1}
{A=1,B=2,A=1}
{B=2,B=2,C=3}
{A=1B=2C=3}
{A=1}B=2}C=3}
{C=3,B=2,A=1,}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end