import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\{(?:(?:A=1()|B=2()|C=3())(?>,|\\}$)){3}\\1\\2\\3$";
final String string = "{A=1,B=2,C=3}\n"
+ "{B=2,A=1,C=3}\n"
+ "{C=3,B=2,A=1}\n"
+ "{A=1,B=2,A=1}\n"
+ "{B=2,B=2,C=3}\n"
+ "{A=1B=2C=3}\n"
+ "{A=1}B=2}C=3}\n"
+ "{C=3,B=2,A=1,}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}