import Foundation
let pattern = #"^\{(?:(?:A=1()|B=2()|C=3())(?>,|\}$)){3}\1\2\3$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
{A=1,B=2,C=3}
{B=2,A=1,C=3}
{C=3,B=2,A=1}
{A=1,B=2,A=1}
{B=2,B=2,C=3}
{A=1B=2C=3}
{A=1}B=2}C=3}
{C=3,B=2,A=1,}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)