package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\s*\?\s*(.*?)\s+\d+(?:\.\d+)?[kM]?`)
var str = ` ? 5girls 57k
? acoustic guitar 1.4k
? bass guitar 4.2k
? black choker 144k
? black dress 227k
? black footwear 275k
? black pants 133k
? black ribbon 128k
? black shirt 201k
? black shorts 117k
? blue eyes 1.7M `
var substitution = "$1,"
fmt.Println(re.ReplaceAllString(str, substitution))
}