# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^\s*\?\s*(.*?)\s+\d+(?:\.\d+)?[kM]?"
test_str = (" ? 5girls 57k\n"
"? acoustic guitar 1.4k\n"
"? bass guitar 4.2k\n"
"? black choker 144k\n"
"? black dress 227k\n"
"? black footwear 275k\n"
"? black pants 133k\n"
"? black ribbon 128k\n"
"? black shirt 201k\n"
"? black shorts 117k\n"
"? blue eyes 1.7M ")
subst = "$1,"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.