const regex = /^\s*\?\s*(.*?)\s+\d+(?:\.\d+)?[kM]?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\s*\\?\\s*(.*?)\\s+\\d+(?:\\.\\d+)?[kM]?', 'gm')
const str = ` ? 5girls 57k
? acoustic guitar 1.4k
? bass guitar 4.2k
? black choker 144k
? black dress 227k
? black footwear 275k
? black pants 133k
? black ribbon 128k
? black shirt 201k
? black shorts 117k
? blue eyes 1.7M `;
const subst = `$1,`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);