import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\s*\\?\\s*(.*?)\\s+\\d+(?:\\.\\d+)?[kM]?";
final String string = " ? 5girls 57k\n"
+ "? acoustic guitar 1.4k\n"
+ "? bass guitar 4.2k\n"
+ "? black choker 144k\n"
+ "? black dress 227k\n"
+ "? black footwear 275k\n"
+ "? black pants 133k\n"
+ "? black ribbon 128k\n"
+ "? black shirt 201k\n"
+ "? black shorts 117k\n"
+ "? blue eyes 1.7M ";
final String subst = "$1,";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}