# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^-L(.+)\s+\K-l(.+)(?=\s+.+)/$1\/$2.a/;t' <<< "-L/usr/local/lib -lmylib -lz"