import Foundation
let pattern = #"^-L(.+)\s+\K-l(.+)(?=\s+.+)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"-L/usr/local/lib -lmylib -lz"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1/$2.a"#
let lookupRange = (testString as NSString).range(of: pattern, options: .regularExpression, range: stringRange)
if lookupRange.intersection(stringRange) != nil {
let result = regex.stringByReplacingMatches(in: testString, range: lookupRange, withTemplate: substitutionString)
print(result)
} else {
print("No matches were found.")
}