re = /^-L(.+)\s+\K-l(.+)(?=\s+.+)/
str = '-L/usr/local/lib -lmylib -lz'
subst = '$1/$2.a'
result = str.sub(re, subst)
# Print the result of the substitution
puts result