using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^-L(.+)\s+\K-l(.+)(?=\s+.+)";
string substitution = @"$1/$2.a";
string input = @"-L/usr/local/lib -lmylib -lz";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}