$re = '/^-L(.+)\s+\K-l(.+)(?=\s+.+)/';
$str = '-L/usr/local/lib -lmylib -lz';
$subst = "$1/$2.a";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;