import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([A-Za-z]{3})\\W([0-9]{2})\\W([0-9]{1,2}\\:[0-9]{1,2}\\:[0-9]{1,2})\\W(?:webapp_prod)(?:.+)(?:account)\\W(\\d+)\\W(?:with email address)\\W((?:[a-zA-Z0-9_.+-]+)\\@(?:[a-zA-Z0-9_.+-]+)\\.(?:[a-zA-Z0-9]+))";
final String string = "Feb 26 16:08:39 webapp_prod [notice] {Itinerator} - anon - null 1890 LoginValidator::execute(): logging in account 40614211 with email address daryl.l.lipscomb@invista.com";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}