$re = '/^([A-Za-z]{3})\W([0-9]{2})\W([0-9]{1,2}\:[0-9]{1,2}\:[0-9]{1,2})\W(?:webapp_prod)(?:.+)(?:account)\W(\d+)\W(?:with email address)\W((?:[a-zA-Z0-9_.+-]+)\@(?:[a-zA-Z0-9_.+-]+)\.(?:[a-zA-Z0-9]+))/m';
$str = 'Feb 26 16:08:39 webapp_prod [notice] {Itinerator} - anon - null 1890 LoginValidator::execute(): logging in account 40614211 with email address daryl.l.lipscomb@invista.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);