// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^([A-Za-z]{3})\W([0-9]{2})\W([0-9]{1,2}\:[0-9]{1,2}\:[0-9]{1,2})\W(?:webapp_prod)(?:.+)(?:account)\W(\d+)\W(?:with email address)\W((?:[a-zA-Z0-9_.+-]+)\@(?:[a-zA-Z0-9_.+-]+)\.(?:[a-zA-Z0-9]+))").unwrap();
let string = "Feb 26 16:08:39 webapp_prod [notice] {Itinerator} - anon - null 1890 LoginValidator::execute(): logging in account 40614211 with email address daryl.l.lipscomb@invista.com";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}