use strict;
my $str = 'Feb 26 16:08:39 webapp_prod [notice] {Itinerator} - anon - null 1890 LoginValidator::execute(): logging in account 40614211 with email address daryl.l.lipscomb@invista.com';
my $regex = qr/^([A-Za-z]{3})\W([0-9]{2})\W([0-9]{1,2}\:[0-9]{1,2}\:[0-9]{1,2})\W(?:webapp_prod)(?:.+)(?:account)\W(\d+)\W(?:with email address)\W((?:[a-zA-Z0-9_.+-]+)\@(?:[a-zA-Z0-9_.+-]+)\.(?:[a-zA-Z0-9]+))/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}