const regex = /^([A-Za-z]{3})\W([0-9]{2})\W([0-9]{1,2}\:[0-9]{1,2}\:[0-9]{1,2})\W(?:webapp_prod)(?:.+)(?:account)\W(\d+)\W(?:with email address)\W((?:[a-zA-Z0-9_.+-]+)\@(?:[a-zA-Z0-9_.+-]+)\.(?:[a-zA-Z0-9]+))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([A-Za-z]{3})\\W([0-9]{2})\\W([0-9]{1,2}\\:[0-9]{1,2}\\:[0-9]{1,2})\\W(?:webapp_prod)(?:.+)(?:account)\\W(\\d+)\\W(?:with email address)\\W((?:[a-zA-Z0-9_.+-]+)\\@(?:[a-zA-Z0-9_.+-]+)\\.(?:[a-zA-Z0-9]+))', 'gm')
const str = `Feb 26 16:08:39 webapp_prod [notice] {Itinerator} - anon - null 1890 LoginValidator::execute(): logging in account 40614211 with email address daryl.l.lipscomb@invista.com`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}