import re
regex = re.compile(r"^([A-Za-z]{3})\W([0-9]{2})\W([0-9]{1,2}\:[0-9]{1,2}\:[0-9]{1,2})\W(?:webapp_prod)(?:.+)(?:account)\W(\d+)\W(?:with email address)\W((?:[a-zA-Z0-9_.+-]+)\@(?:[a-zA-Z0-9_.+-]+)\.(?:[a-zA-Z0-9]+))", flags=re.MULTILINE)
test_str = "Feb 26 16:08:39 webapp_prod [notice] {Itinerator} - anon - null 1890 LoginValidator::execute(): logging in account 40614211 with email address daryl.l.lipscomb@invista.com"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")