#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im)^[_a-z0-9-\+.-]+(\.[_a-z0-9-]+)*@?([a-z0-9+\-]+\.)*[a-z0-9+\-]*$"
Local $sString = "u" & @CRLF & _
"us" & @CRLF & _
"user@" & @CRLF & _
"user@@" & @CRLF & _
"user@dom" & @CRLF & _
"user@example.com" & @CRLF & _
"user@example..com" & @CRLF & _
"user@@www.example.com" & @CRLF & _
"u@w.e..com"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")