re = /^[_a-z0-9-\+.-]+(\.[_a-z0-9-]+)*@?([a-z0-9+\-]+\.)*[a-z0-9+\-]*$/im
str = 'u
us
user@
user@@
user@dom
user@example.com
user@example..com
user@@www.example.com
u@w.e..com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end