const regex = /^[_a-z0-9-\+.-]+(\.[_a-z0-9-]+)*@?([a-z0-9+\-]+\.)*[a-z0-9+\-]*$/gim;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[_a-z0-9-\\+.-]+(\\.[_a-z0-9-]+)*@?([a-z0-9+\\-]+\\.)*[a-z0-9+\\-]*$', 'gim')
const str = `u
us
user@
user@@
user@dom
user@example.com
user@example..com
user@@www.example.com
u@w.e..com`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}