package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?im)^[_a-z0-9-\+.-]+(\.[_a-z0-9-]+)*@?([a-z0-9+\-]+\.)*[a-z0-9+\-]*$`)
var str = `u
us
user@
user@@
user@dom
user@example.com
user@example..com
user@@www.example.com
u@w.e..com`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}