import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[_a-z0-9-\\+.-]+(\\.[_a-z0-9-]+)*@?([a-z0-9+\\-]+\\.)*[a-z0-9+\\-]*$";
final String string = "u\n"
+ "us\n"
+ "user@\n"
+ "user@@\n"
+ "user@dom\n"
+ "user@example.com\n"
+ "user@example..com\n"
+ "user@@www.example.com\n"
+ "u@w.e..com";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}