package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\d+\,(?:\d+\,?)+$`)
var str = `1,2,3,5
1,23
1|46|6778|567
1,278,3780,50
57,,,,,,578678,678,67,678,678,,,,,6,78,6`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}