re = /^\d+\,(?:\d+\,?)+$/m
str = '1,2,3,5
1,23
1|46|6778|567
1,278,3780,50
57,,,,,,578678,678,67,678,678,,,,,6,78,6'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end