const regex = /^\d+\,(?:\d+\,?)+$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\d+\\,(?:\\d+\\,?)+$', 'gm')
const str = `1,2,3,5
1,23
1|46|6778|567
1,278,3780,50
57,,,,,,578678,678,67,678,678,,,,,6,78,6`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}