use strict;
my $str = '1,2,3,5
1,23
1|46|6778|567
1,278,3780,50
57,,,,,,578678,678,67,678,678,,,,,6,78,6';
my $regex = qr/^\d+\,(?:\d+\,?)+$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}