import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\d+\\,(?:\\d+\\,?)+$";
final String string = "1,2,3,5\n"
+ "1,23\n"
+ "1|46|6778|567\n"
+ "1,278,3780,50\n"
+ " 57,,,,,,578678,678,67,678,678,,,,,6,78,6";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}