using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<p>@@@LINK=(.+?)</p>";
string substitution = @"<a href=""x-dictionary:d:\g<1>:dict_bundle_id"">\g<1></a>";
string input = @"<p>@@@LINK=ten pence</p>
<p>@@@LINK=twenty-twenty vision</p>
<p>@@@LINK=fifty pence</p>
<p>@@@LINK=abate</p>";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}