import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<p>@@@LINK=(.+?)</p>";
final String string = "<p>@@@LINK=ten pence</p>\n"
+ "<p>@@@LINK=twenty-twenty vision</p>\n"
+ "<p>@@@LINK=fifty pence</p>\n"
+ "<p>@@@LINK=abate</p>";
final String subst = "<a href=\"x-dictionary:d:\\g<1>:dict_bundle_id\">\\g<1></a>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}