const regex = new RegExp('<p>@@@LINK=(.+?)</p>', 'gm')
const str = `<p>@@@LINK=ten pence</p>
<p>@@@LINK=twenty-twenty vision</p>
<p>@@@LINK=fifty pence</p>
<p>@@@LINK=abate</p>`;
const subst = `<a href="x-dictionary:d:\g<1>:dict_bundle_id">\g<1></a>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);