#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?:\b[_a-zA-Z]|\B\$)[_$a-zA-Z0-9]*+"
Local $sString = "aaa" & @CRLF & _
"sales_tax" & @CRLF & _
"_circleArea" & @CRLF & _
"box100width" & @CRLF & _
"$directory" & @CRLF & _
"ab1234$$" & @CRLF & _
"$alpha$"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")