package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:\b[_a-zA-Z]|\B\$)[_$a-zA-Z0-9]*+`)
var str = `aaa
sales_tax
_circleArea
box100width
$directory
ab1234$$
$alpha$`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}