const regex = /(?:\b[_a-zA-Z]|\B\$)[_$a-zA-Z0-9]*+/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\b[_a-zA-Z]|\\B\\$)[_$a-zA-Z0-9]*+', 'g')
const str = `aaa
sales_tax
_circleArea
box100width
\$directory
ab1234\$\$
\$alpha\$`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}