using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(\/\w+)((\/\w+){3})\.(gif|jpg)";
string input = @"/hDfpiC4m4EnExfONLSlj2k6bkvw/lj/sn/0949bb8fd87f7b8762d001955d0d219b.png";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}