const regex = /^(\/\w+)((\/\w+){3})\.(gif|jpg)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\\/\\w+)((\\\/\\w+){3})\\.(gif|jpg)', '')
const str = `/hDfpiC4m4EnExfONLSlj2k6bkvw/lj/sn/0949bb8fd87f7b8762d001955d0d219b.png`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}