// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"^(\/\w+)((\/\w+){3})\.(gif|jpg)").unwrap();
let string = "/hDfpiC4m4EnExfONLSlj2k6bkvw/lj/sn/0949bb8fd87f7b8762d001955d0d219b.png";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}