package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(\/\w+)((\/\w+){3})\.(gif|jpg)`)
var str = `/hDfpiC4m4EnExfONLSlj2k6bkvw/lj/sn/0949bb8fd87f7b8762d001955d0d219b.png`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}