import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\/\\w+)((\\/\\w+){3})\\.(gif|jpg)";
final String string = "/hDfpiC4m4EnExfONLSlj2k6bkvw/lj/sn/0949bb8fd87f7b8762d001955d0d219b.png";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}