using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\s?on\w+=""[^""]+""\s?";
string substitution = @"";
string input = @"<body>
<script src=""..."">
</script>
<div onresize=""CreateFixedHeaders()"" onscroll=""CreateFixedHeaders()"" id=""oReportDiv"" style=""overflow:auto;WIDTH:100%"">
<script type=""text/javascript"" language=""javascript"">
//<![CDATA[
function CreateFixedHeaders() {}//]]>
</script>
<script>
var ClientReportfb64a4706a3749c484169e...
</script>
</body>";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}