// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"\s?on\w+="[^"]+"\s?"#).unwrap();
let string = "<body>
<script src=\"...\">
</script>
<div onresize=\"CreateFixedHeaders()\" onscroll=\"CreateFixedHeaders()\" id=\"oReportDiv\" style=\"overflow:auto;WIDTH:100%\">
<script type=\"text/javascript\" language=\"javascript\">
//<![CDATA[
function CreateFixedHeaders() {}//]]>
</script>
<script>
var ClientReportfb64a4706a3749c484169e...
</script>
</body>";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}