import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\s?on\\w+=\"[^\"]+\"\\s?";
final String string = "<body>\n"
+ "<script src=\"...\">\n\n"
+ " </script>\n"
+ "<div onresize=\"CreateFixedHeaders()\" onscroll=\"CreateFixedHeaders()\" id=\"oReportDiv\" style=\"overflow:auto;WIDTH:100%\">\n\n"
+ "<script type=\"text/javascript\" language=\"javascript\">\n\n"
+ "//<![CDATA[\n\n"
+ "function CreateFixedHeaders() {}//]]>\n"
+ "</script>\n"
+ "<script>\n\n"
+ " var ClientReportfb64a4706a3749c484169e...\n"
+ " </script>\n"
+ "</body>";
final String subst = "";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}