using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([^\s\-_A-Z]+)|([A-Z]+[^\s\-_A-Z]*)";
string input = @"InPascalCase
inCamelCase
in-kebab-case
in_snake_case
in-kebab_snake
in_snake-kebab
inCamel-kebab
inCamel_snake
InPascal-kebab
InPascal_snake
inCamel-kebab_snake
inCamel_snake-kebab
in_snakeCamel-kebab
in_snake-kebabCamel
in_snakeCamelCamel-kebab
in-kebabCamel_snakeCamel-kebab_snake";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}