import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([^\\s\\-_A-Z]+)|([A-Z]+[^\\s\\-_A-Z]*)";
final String string = "InPascalCase\n"
+ "inCamelCase\n"
+ "in-kebab-case\n"
+ "in_snake_case\n"
+ "in-kebab_snake\n"
+ "in_snake-kebab\n"
+ "inCamel-kebab\n"
+ "inCamel_snake\n"
+ "InPascal-kebab\n"
+ "InPascal_snake\n"
+ "inCamel-kebab_snake\n"
+ "inCamel_snake-kebab\n"
+ "in_snakeCamel-kebab\n"
+ "in_snake-kebabCamel\n"
+ "in_snakeCamelCamel-kebab\n"
+ "in-kebabCamel_snakeCamel-kebab_snake";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}