import Foundation
let pattern = #"([^\s\-_A-Z]+)|([A-Z]+[^\s\-_A-Z]*)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
InPascalCase
inCamelCase
in-kebab-case
in_snake_case
in-kebab_snake
in_snake-kebab
inCamel-kebab
inCamel_snake
InPascal-kebab
InPascal_snake
inCamel-kebab_snake
inCamel_snake-kebab
in_snakeCamel-kebab
in_snake-kebabCamel
in_snakeCamelCamel-kebab
in-kebabCamel_snakeCamel-kebab_snake
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)