import re
regex = re.compile(r"([^\s\-_A-Z]+)|([A-Z]+[^\s\-_A-Z]*)")
test_str = ("InPascalCase\n"
"inCamelCase\n"
"in-kebab-case\n"
"in_snake_case\n"
"in-kebab_snake\n"
"in_snake-kebab\n"
"inCamel-kebab\n"
"inCamel_snake\n"
"InPascal-kebab\n"
"InPascal_snake\n"
"inCamel-kebab_snake\n"
"inCamel_snake-kebab\n"
"in_snakeCamel-kebab\n"
"in_snake-kebabCamel\n"
"in_snakeCamelCamel-kebab\n"
"in-kebabCamel_snakeCamel-kebab_snake")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")